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How to Fix Moodle’s Document Issues with 
Guidance 

Blackboard Ally is the designated accessibility tool integrated into our university’s 
Moodle. It serves as a critical resource for enhancing the accessibility of online 
course content. This guidance is specifically tailored to help you fix common 
document issues that Ally detects. By following the steps and recommendations 
outlined here, you can ensure that your course materials meet Ally’s standards of 
accessibility, making learning more inclusive for students.  

Note: All software versions mentioned in this guidance, including PDF, Microsoft 
Word, and PowerPoint, are updated to match the University’s software versions, 
such as Adobe Acrobat and Microsoft 365. You may need to adjust the fixing process 
if you are using a different version. 
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1. Document: The document is scanned but not OCRed (Severe) 

What this means: The file is an image-only PDF created by scanning a physical 
document. Because it has not been processed with Optical Character Recognition 
(OCR), the text cannot be read by screen readers, searched, or copied. This makes 
the content inaccessible to visually impaired students and difficult for others to use 
effectively. This issues normally happened when you upload a scanned PDF or 
a Mentimeter exported PDF.  

 

How to fix: 

• Use an OCR tool to convert the scanned PDF into a text-based PDF: 
• In Adobe Acrobat Pro, go to All tools → Scan & OCR → In this file → 

Recognize Text. 
• Free alternatives include Microsoft OneNote, or online OCR services. 
• Check the output to ensure the recognised text is accurate. 
• If OCR is not possible, provide the content in an alternative accessible format 

(e.g., Word document or HTML page). 
• Re-upload the corrected file through Ally. 

 

2. Document: The document is malformed (Severe) 

What this means: Ally cannot process this document because the file itself is 
corrupted or created in a way that does not follow standard PDF/Word formatting 
rules. This means it may not open correctly, some content may be missing, and 
accessibility checks cannot run. Students may be unable to view or use the file 
properly.  

How to fix: 

• Try opening the document yourself to confirm whether it works. 
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• If it opens, save a new copy using “Save As” in Word, PowerPoint, or 
Acrobat to repair the structure. 

• If it does not open, re-create the document from the original source (e.g., re-
export the file from Word, PowerPoint, or another authoring tool). 

• Always save documents using standard formats (e.g., .docx for Word, .pptx 
for PowerPoint, or properly exported PDF). 

• Re-upload the corrected version to Ally. 

 

3. Document: The document is encrypted (Severe) 

What this means: This file is password-protected or has restrictions that prevent 
Ally from reading and checking it. Encrypted documents block accessibility tools (like 
screen readers), meaning students with disabilities cannot access the content. Even 
students without disabilities may not be able to open or use the file if they don’t have 
the password. 

How to fix: 

• Open the original file and remove the password or restrictions: 
o In Word or PowerPoint: File → Info → Protect Document → Remove 

Password. 
o In Adobe Acrobat: Menu → Document Properties → Security Method → 

No Security. 
• Save the unprotected version in the correct format (e.g., Word, PowerPoint, or 

accessible PDF). 
• Re-upload the accessible file to Ally. 
• If sensitive information requires password protection, provide an alternative 

accessible version (e.g., a separate Word or PDF without restrictions) for 
student use. 

• If you cannot remove encryption immediately, copy the key content into a new, 
unprotected document and upload that as a temporary accessible version. 

 

4. Document: The document has contrast issues (Major) 

What this means: The text and background colours in the document do not meet 
accessibility contrast standards. For example, grey text on a white slide, or light-
coloured text on a patterned background, can make reading difficult. Students with 
low vision, colour vision deficiency, or those viewing on small/mobile screens may 
struggle to see the content clearly. 

How to fix: 

 



4 
Created by Jingyang Ai 
Last Updated: 2025/10/01 

• Adjust the text colour and/or background colour to ensure good contrast 
(at least a 4.5:1 ratio for normal text). 

• Use accessible colour palettes or check your choices with tools like the 
WebAIM: Contrast Checker. 

• Avoid using colour alone to highlight meaning, combine colour with bold, 
underline, or patterns if emphasis is needed. 

• Save the updated file and re-upload it in Ally. 
• If you cannot change the design quickly (e.g., in a slide deck), provide the 

core content in plain text (Word or PDF) alongside the original file, so students 
have an immediate accessible option. 

 

 

 

5. Document: The document contains images without a description (Major) 

What this means: The document includes images that do not have alternative text 
(alt text). Alt text is essential for screen reader users, as it provides a description of 
the image. Without it, students with visual impairments miss important information. 
Even for sighted users, alt text helps when images fail to load. 

How to fix: 

• Add alternative text to each meaningful image: 
o In Word/PowerPoint: Right-click the image → View Alt Text → type a 

short description. 
o In Adobe Acrobat: Set Alternate Text under Accessibility tools through All 

tools → Prepare for accessibility → Add alternative text. 
• Keep descriptions concise and focused on the purpose of the image (e.g., 

“Flowchart showing the research process”). 

https://webaim.org/resources/contrastchecker/
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• If the image is purely decorative, mark it as decorative (Word/PowerPoint 
allow you to tick “Mark as decorative”). 

• Save and re-upload the corrected document through Ally. 
• If short on time, provide a text summary of the image’s key points directly in 

the document near the image until you can add proper alt text. 

 

 

 

6. Document: The document is untagged (Major) 

What this means: This means the PDF does not contain tags that define its 
structure (headings, paragraphs, lists, tables, etc.). Tags are vital because they allow 
screen readers to interpret the content correctly and let students navigate the 
document by sections. An untagged PDF appears as one block of text, which is 
inaccessible and confusing for many learners. 

How to fix: 

• In Adobe Acrobat Pro: 
o Go to All tools → Prepare for accessibility → Automatically tag PDF. 
o Review the tags created and adjust them if needed (e.g., ensure headings, 

lists, and tables are correctly marked). 
• If you created the document in Word/PowerPoint, make sure to use proper 

heading styles and structure, then export as PDF (Save As → PDF → Options 
→ Document structure tags for accessibility). 

• Re-upload the correctly tagged PDF through Ally. 
• If you don’t have access to Acrobat Pro, share the original Word/PowerPoint 

document instead of the untagged PDF, Ally can check the accessibility of the 
source file. 
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7. Document: The document does not have any headings (Major) 

 

What this means: The document contains only plain text and has no defined 
headings. Without headings, screen readers cannot provide a logical structure for 
navigation, and students cannot quickly move between sections. This makes the 
document harder to read and less accessible for everyone, especially in long or 
complex documents. 

How to fix: 

• Open the original file (e.g., Word or PowerPoint). 
• Apply proper heading styles instead of just bold or larger font sizes: 

o Heading 1 (H1) for the document title. 
o Heading 2 (H2) for main sections. 
o Heading 3 (H3) (or lower) for subsections. 

• In Word: Home → Styles → Heading 1/2/3. 
• Re-export the document to PDF with accessibility tags included (Save As → 

PDF). 
• Re-upload the corrected version to Ally. 
• If you don’t have time to restructure the entire file, add at least basic section 

headings (e.g., Introduction, Methods, Conclusion) so students can navigate 
the document more easily. 

 

8. Document: The document has tables that don’t have any headers (Major) 
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What this means: The document includes tables, but no header rows or columns 
are defined. Screen readers need headers to explain the relationship between the 
data in each cell. Without them, students using assistive technology cannot make 
sense of the table’s structure, making the content confusing or inaccessible. 

How to fix: 

• In Word: 
o Click inside the table → Table Tools → Design → Header Row (tick the 

box). 
o Ensure the first row (or column, if appropriate) contains clear labels for the 

data. 
• In Excel: Use the top row for headers and ensure they are descriptive. 
• Re-export to PDF with accessibility tags (Save As → PDF → Options → 

Document structure tags for accessibility). 
• Re-upload the corrected file to Ally. 
• If you cannot edit the table quickly, provide the data in plain text (e.g., a list or 

paragraph explanation) alongside the table so students can access the 
information. 

 

9. Document: The document is scanned and OCRed (Major) 

What this means: 

The document was scanned and then processed with Optical Character 
Recognition (OCR) so text can be read by screen readers. However, OCR output is 
often imperfect, formatting, heading structure, or text accuracy may be poor. This 
makes the document harder to navigate and may still cause accessibility problems 
for students. 

How to fix: 
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• Open the OCRed document and check the text quality: 
o Correct spelling or recognition errors. 
o Reapply proper heading styles for structure. 
o Ensure tables, lists, and images have the right tags and alt text. 

• If the document is very large or messy, consider recreating it from the original 
source (e.g., retyping or reformatting in Word/PowerPoint). 

• Re-save and re-upload the cleaned version to Ally. 
• If you cannot fully reformat the OCRed document right away, provide a 

separate plain-text version (e.g., in Word) so students can access the content 
while you improve the scanned file. 

 

10. Document: The document is missing a title (Minor) 

 

What this means: The document does not have a defined title in its properties. 
While the file may contain a heading on the first page, accessibility tools rely on the 
document title field to identify the file. Without it, screen readers may only announce 
the file name, which is often unclear (e.g., “Lecture_Week3_v2_final.pdf”). 

How to fix: 

• In Word/PowerPoint: Go to File → Info → Properties → Title, and type a 
clear title (e.g., “Introduction to Research Methods”). 

• In Adobe Acrobat: Go to Menu → Document Properties → Description → 
Title and add a meaningful title. 

• Save the updated file and re-upload it through Ally. 
• If you are short on time, ensure the first page of the document contains a 

clear heading so that students at least see the correct title visually. 
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11. Document: The document does not have a language set (Minor) 

What this means: The document does not specify its default language. Screen 
readers use the language setting to apply correct pronunciation rules. Without it, the 
tool may mispronounce words, especially in documents with specialist terms or when 
multiple languages are used. 

How to fix: 

• In Word: 
o Review → Language → Set Proofing Language → Choose English (UK) 

(or the appropriate language). 
o Tick “Do not check spelling or grammar” only if needed. 

• In Adobe Acrobat: Menu → Document Properties → Advanced → Reading 
Options → Language → Select the correct language. 

• Save the document and re-upload it in Ally. 
• If you cannot change the document properties quickly, make sure the main 

language is clear in the text itself (e.g., add “All content in this document is in 
English (UK)”). 

 

Note: 

1. Accessibility Report Update: Please allow at least 30 minutes for updates 
due to lag issues.  

2. Outdated Issues: Some issues may appear outdated as Moodle and Ally 
software are updated. Most are considered minor, such as “The HTML content 
does not have a language set”. These will no longer appear in future Moodle 
builds. 

3. Heading Structure: In Moodle, we already utilise tags H1 and H2 for the web 
page design, so the largest font in the Moodle editor starts from H3 tag. It is 
crucial to be mindful of this structure as it can affect the experience of screen 
reader users, whose devices navigate based on HTML heading structure. 

4. Ally Detection Limitations: Not all issues detected by Ally will be illustrated. 
Even if detected, be aware that your content might still be inaccessible based 
on Ally’s descriptions, including issues with contrast, heading structure, etc. 

5. If you need further information or guidance, please visit the following link: 
https://moodlecurrent.gre.ac.uk/mod/book/view.php?id=2726546  

https://moodlecurrent.gre.ac.uk/mod/book/view.php?id=2726546
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